The cinder.volume.drivers.falconstor.iscsi Module

The cinder.volume.drivers.falconstor.iscsi Module

Volume driver for FalconStor FSS storage system.

This driver requires FSS-8.00-8865 or later.

class FSSISCSIDriver(*args, **kwargs)

Bases: cinder.volume.drivers.falconstor.fss_common.FalconstorBaseDriver, cinder.volume.driver.ISCSIDriver

Implements commands for FalconStor FSS ISCSI management.

To enable the driver add the following line to the cinder configuration:
volume_driver=cinder.volume.drivers.falconstor.iscsi.FSSISCSIDriver
CI_WIKI_NAME = 'FalconStor_CI'
SUPPORTED = False
VERSION = '4.0.0'
initialize_connection(volume, connector, initiator_data=None)
terminate_connection(volume, connector, **kwargs)

Terminate connection.

Creative Commons Attribution 3.0 License

Except where otherwise noted, this document is licensed under Creative Commons Attribution 3.0 License. See all OpenStack Legal Documents.