The ironic.api.controllers.base Module

The ironic.api.controllers.base Module

class ironic.api.controllers.base.APIBase(**kw)[source]

Bases: wsme.types.Base

as_dict()[source]

Render this object as a dict of its fields.

unset_fields_except(except_list=None)[source]

Unset fields so they don’t appear in the message body.

Parameters:except_list – A list of fields that won’t be touched.
class ironic.api.controllers.base.Version(headers, default_version, latest_version)[source]

Bases: object

API Version object.

static parse_headers(headers, default_version, latest_version)[source]

Determine the API version requested based on the headers supplied.

Parameters:
  • headers – webob headers
  • default_version – version to use if not specified in headers
  • latest_version – version to use if latest is requested
Returns:

a tuple of (major, minor) version numbers

Raises:

webob.HTTPNotAcceptable

Creative Commons Attribution 3.0 License

Except where otherwise noted, this document is licensed under Creative Commons Attribution 3.0 License. See all OpenStack Legal Documents.