Ussuri Series Release Notes

2.0.0

Upgrade Notes

  • Python 2.7 support has been dropped. Last release of ironic-prometheus-exporter to support Python 2.7 is OpenStack Train. The minimum version of Python now supported by ironic-prometheus-exporter is Python 3.6.

Bug Fixes

  • Fixes the bug in the redfish parser that would raise Duplicated timeseries in CollectorRegistry: {‘metric_name’} when a metric have more that one value and different values for the labels.

  • Fixes the value for instance_uuid field when the value is None in all parsers, we will use the same value of node_uuid in instance_uuid.