Current Series Release Notes

2.19.0-12

Upgrade Notes

  • Python 2.7 support has been dropped. The last release of openstack/manila-ui to support py2.7 is OpenStack Train (2.19.x). The minimum version of Python now supported by openstack/manila-ui is Python 3.6.

Bug Fixes

  • “snapshot_support” is no longer automatically included as an extra-spec in share types created via manila-ui. If the share type has to match backends that support snapshots, explicitly specify “snapshot_support” in the “Extra specs” field while creating share types. This change does not modify pre-existing share types.

  • Fixed issue that the saved Share quota data is not shown in Modify Quotas modal dialog.