Compatibility Notes

Useful notes about errors users may encounter when features cannot be supported on older versions of setuptools / pip / wheel.



evaluate_markers may run into issues with the ‘>’, ‘>=’, ‘<’, and ‘<=’ operators if the installed version of setuptools is less than 17.1. Projects using these operators with markers should specify a minimum version of 17.1 for setuptools.



For versions of pip < 7 with pbr < 1.9, dependencies that use markers will not be installed. Projects using pbr and markers should set a minimum version of 1.9 for pbr.


Version 1.5.0+

The warning-is-error flag is only supported by Sphinx 1.5 and will cause errors when used with older versions.