Supported Platforms

The following OS/version are supported by the Puppet modules:

  • RHEL / CentOS 7

  • Ubuntu 16.04 (Xenial) with Ocata up to Queens

  • Ubuntu 18.04 (Bionic) with Rocky and beyond

  • Debian 9.0 (Stretch) with Rocky and beyond

The modules are tested on Puppet 4 up to Queens and then Puppet 5 and 6 from there.

Puppet 3 or earlier is NOT supported. Puppet 4 is NOT supported as of the Train release.

See Continuous Integration to see what is currently tested.