Current Series Release Notes

3.1.0-12

New Features

  • A new config option, queue_buffering_max_messages, has been added to support controlling the size of posts to Kafka from the Monasca API.

Upgrade Notes

  • Python 2.7 support has been dropped. Last release of monasca-api to support python 2.7 is OpenStack Train. The minimum version of Python now supported by monasca-api is Python 3.6.