Victoria Series Release Notes

17.5.0

New Features

  • Add new configuration option ‘rbd_thin_provisioning’ and ‘filesystem_thin_provisioning’ to rbd and filesystem backends to enable or not sparse upload, default are False.

17.4.0

New Features

  • Added disk_formats option which allows configuration of the image_format/disk_formats config setting; some backends perform poorly with specific disk formats, for example Ceph with QCOW2 images and in these scenarios it might be useful to filter out of the allowed disk formats those which are unwanted.

17.3.0

New Features

  • The following new parameters have been added, which can be used to set the interface parameter in authtoken middleware.

    • glance::api::authtoken::interface

    • glance::registry::authtoken::interface

Upgrade Notes

  • The glance::registry class and its subsequent classes have been removed. This means that support for glance-registry service has been removed.

Deprecation Notes

  • The glance::api::enable_v2_api parameter has been deprecated and has no effect now.

  • The following parameters have been deprecated and has no effect now, in favor of removal of support for glance registry service.

    • glance::api::registry_client_cert_file

    • glance::api::registry_client_key_file

    • glance::api::registry_client_ca_file

    • glance::config::registry_config

    • glance::config::registry_paste_ini_config

  • The following resource types have been deprecated and will be removed in a future release.

    • glance_registry_config

    • glance_registry_paste_ini

17.1.0

New Features

  • Added cache_prefetcher_interval in glance-api.conf, using which the periodic job will run as per the set interval and prefetch images into cache.

  • Add new options glance::backend::multibackend::swift::swift_buffer_on_upload and glance::backend::multibackend::swift::swift_upload_buffer_dir Indicate whether or not Glance should buffer image data to disk while uploading to swift. This enables Glance to resume uploads on error.

Deprecation Notes

  • The glance::api::enable_v1_api parameter has been deprecated and has no effect, infavor of deprecation of Image v1 API.