[ English | 한국어 (대한민국) | English (United Kingdom) | Indonesia | Deutsch | français | русский ]

Contoh menimpa sumber

Ada situasi di mana seorang deployer ingin menimpa sumber dengan fork sendiri.

Bab ini memberikan contoh kasus per kasus tentang cara mengganti sumber default.

Mengganti versi Ansible

Meng-override versi Ansible default tidak disarankan, karena setiap branch dari OpenStack-Ansible telah dibangun dengan mempertimbangkan versi Ansible yang spesifik, dan banyak perubahan Ansible tidak kompatibel maju ataupun mundur (backwards nor forward)

Skrip bootstrap-ansible.sh menginstal Ansible, dan menggunakan variabel ANSIBLE_PACKAGE untuk menjelaskan versi mana yang akan diinstal.

Misalnya untuk menginstal ansible version 2.5.0:

$ export ANSIBLE_PACKAGE="ansible==2.5.0"

Menginstal langsung dari git juga didukung. Misalnya, dari ujung branch pengembangan Ansible:

$ export ANSIBLE_PACKAGE="git+https://github.com/ansible/ansible@devel#egg=ansible"

Mengesampingkan role

Mengganti file role telah dijelaskan dalam panduan referensi, pada bagian Menambahkan peran baru atau utama dalam instalasi OpenStack-Ansible Anda.

Mengganti kode sumber proyek hulu (upstream) lainnya

Semua repositori hulu yang digunakan didefinisikan dalam repositori terintegrasi openstack-ansible, dalam folder playbooks/defaults/repo_packages.

Misalnya, jika Anda ingin mengganti repositori glance dengan milik Anda sendiri, Anda perlu mendefinisikan yang berikut:

glance_git_repo: https://<your git repo>
glance_git_install_branch: <your git branch or commit SHA>
glance_git_project_group: glance_all

Harap perhatikan, untuk contoh glance ini, bahwa Anda tidak perlu mengedit file playbooks/defaults/repo_packages/openstack_services.yml.

Sebagai gantinya, mekanisme penggantian yang biasa dapat terjadi, dan Anda dapat mendefinisikan 3 variabel ini dalam file user_*.yml. Lihat juga halaman Mengganti konfigurasi default.

Catatan

Variabel ini berperilaku sedikit berbeda dari presedensi ansible standar, karena mereka juga dikonsumsi oleh plugin pencarian kustom (custom lookup plugin).

The py_pkgs lookup akan mengabaikan variabel all _git_ kecuali variabel _git_repo ada.

Jadi, bahkan jika Anda hanya ingin mengganti _git_install_branch untuk repositori, Anda juga harus mendefinisikan variabel _git_repo dalam variabel pengguna Anda.