Pike Series Release Notes

Pike Series Release Notes

7.4.10

Upgrade Notes

  • Validate that there are no volumes formatted with XFS and ftype=0. Deployments from OpenStack Kilo or Liberty have XFS partitions formatted with ftype=0, which is incompatible with the docker overlayfs driver. From OpenStack Newton, we have support for XFS ftype=1 by default. This check will make fail the pre-upgrade validations if there are deployments coming back from Kilo or Liberty and have XFS partitions with ftype=0.

7.4.3

New Features

  • Ansible-style module documentation has been added to our custom modules so they can be described with the ansible-doc command.

7.3.0

Bug Fixes

  • The ansible_ssh_user in the generated inventory by tripleo-ansible-inventory is now configurable instead of hardcoded to heat-admin. The default is still heat-admin. Use the –ansible_ssh_user param or the ANSIBLE_SSH_USER env var to define a custom value.

7.2.0

New Features

  • Adds simple undercloud service list (static) to the inventory and uses that for pre-upgrade/update check that services are OK.
  • Adds a validation to the pre-upgrade group that checks if current repositories can be connected to and if there is at least one repo configured in yum repolist.
  • Added a network environment validation that checks network settings based on environments/network-environment.yaml and nic config files stored in the plan’s Swift container.
  • Updated the network environment validation to use the new schema-based validation method that would detect more error cases.
  • New validation to check the health of the current stack; to be run before an update or upgrade.
  • New lookup plugin to access the current stack’s resources in Ansible playbooks.

7.1.0

New Features

  • Added a lookup plugin to access or loop over the current plan’s template files in a validation playbook.

7.0.0

New Features

  • Adds a ceph-health check which prints a warning message if Ceph cluster is in HEALTH_WARN state at the end of the Overcloud deployment
  • Add a new warn ansible module that simply adds a string to the ‘warnings’ ansible output.
  • Migrate tripleo-ansible-inventory to use keystoneauth instead of keystoneclient.
Creative Commons Attribution 3.0 License

Except where otherwise noted, this document is licensed under Creative Commons Attribution 3.0 License. See all OpenStack Legal Documents.