Current Series Release Notes

20.3.0-32

New Features

  • The ironic::wsgi::apache class now supports customizing request/response headers added by apache.

  • The new ironic::conductor::deploy_callback_timeout parameter has been added.

  • The ironic::conductor class now supports the following two new parameters.

    • heartbeat_interval

    • heartbeat_timeout

  • The pxe parameter uefi_pxe_bootfile_name is now managed by puppet, keeping the ironic default of bootx64.efi.

    The shim EFI binary is copied to the TFTP root directory, to a file named the value of uefi_pxe_bootfile_name. The grub EFI binary is copied to the TFTP root directory to a file named grubx64.efi.

    With these changes, using the pxe boot driver with UEFI boot will result in a grub network boot which is Secure Boot capable.

Upgrade Notes

  • Default value of the ironic::wsgi::apache::ssl parameter has been changed from true to false and now ssl is disabled by default.

  • CentOS 8 Stream is no longer supported by this module.

  • The ironic::conductor::api_url parameter has been removed.

  • The ironic::conductor::configdrive_use_swift parameter has been removed.

  • The ironic::conductor::inspect_timeout parameter has been removed.

  • The ironic::drivers::pxe::ipxe_enabled parameter has been removed.

  • The ironic::glance::api_servers parameter and the ironic::neutron::api_servers parameter have been removed.

  • The ironic::drivers::inspector::service_url parameter has been removed.

  • The ironic::pxe::enable_ppc64le parameter has been removed.

  • The ironic::driver::pxe::pxe_append_params parameter has been removed.

Bug Fixes

  • Now the ironic::pxe class properly installs the pxelinux.0 file using the separate pxelinux package in Debian and Ubuntu. The new pxelinux_file_path parameter can be used to determine the source path to locate the file. When this parameter is set to false then the class does not manage the file.

  • The wrong source directory to copy syslinux files in Debiand or Ubuntu has been fixed.

  • Now the tftpd-hap package is installed insted of the tftpd package in Debian and Ubuntu.